Cisco Dynamic IP Configuration

service udp-small-servers
service tcp-small-servers
!
hostname Router
!
enable secret ########
!
ip subnet-zero
isdn switch type basic-ni1
!
interface ethernet0
  ip address 192.168.0.1 255.255.255.0
  ip nat inside
! 
interface BRI0
  no ip address
  no ip address
  encapsulation ppp
  dialer rotary-group 0
  isdn spid1 21440797860101 4079786
  isdn spid2 21440797680101 4079768
  no fair-queue
  no cdp enable
!
interface Dialer0
  ip address negotiated
  encapsulation ppp
  ip nat outside
  dialer remote-name dallas
  dialer idle-timeout 300
  dialer load-threshold 50 either
  dialer string 2145555555
  dialer-group 1
  no fair-queue
  no cdp enable
  ppp authentication pap callin
  ppp pap sent-username MYUSERNAME password MYPASSWORD
  ppp multilink
!
ip classless
ip route 0.0.0.0 0.0.0.0 dialer0
access-list 101 permit ip 192.168.0.1 0.0.0.255 any
dialer-list 1 protocol ip list 101
ip nat inside source list 101 interface dialer 0 overload
!
line con 0
  password CONSOLEPASSWORD
  login
line aux0
line vtr 0 4
  password TELNETPASSWORD
  login
!
For further information on the Cisco ISDN configuration and for troubleshooting connectivity problems, please see the Cisco ISDN Configuration Guide.