Online Quizzes

Building Scalable Cisco Networks (BSCN)

This quiz is designed to test your preparedness for the BSCN (640-503) exam. Many of these questions closely mirror what you will actually see in the exam, so study closely any of those questions that you miss and you should succeed at passing the exam. Good Luck!


    1. What will most likely occur when all frame relay interfaces belong to area 0 in a multi-area OSPF network?

    Type-5 LSA's will not be delivered.
    External summary routes cannot be used.
    Summary LSA's will be flooded throughout the area and all area 0 routers will recalculate their routing tables in response to a topology change in area 0.
    The topology will never be implemented because full-time circuit tariffs are prohibited.

    2. The _____________ command is used to verify the status of an OSPF virtual link.

    show ip ospf
    show ip ospf database
    show ip ospf interface
    show ip ospf virtual-links

    3. An OSPF ABR connects _____________ .

    Multiple OSPF areas.
    OSPF and RIP networks.
    OSPF and EIGRP networks.
    Multiple designated routers.

    4. What OSPF feature allows a single large area to be separated into smaller areas?

    Link-state.
    Hierarchical.
    Interior area.
    OSPF subarea.

    5. You make an OSPF area into a subarea. All routers in the area exchange routing information. However, when you configure the ABR for stub, it no longer exchanges information with other routers in its area. What is most likely the problem?

    There is an ASBR in area 2.
    Area 2 is a transit area for virtual links.
    The router in area 2 also needs to be configured for stub.
    Area 2 has multiple exit point ABR''s and only one is configured for stub.

    6. What capability of OSPF allows it to support variable length subnet masking (VLSM) ?

    OSPF can perform route summarization
    OSPF carries subnet mask confirmation in link advertisements.
    OSPF is a link state protocol.
    OSPF design requires addresses to be allocated in groups to support multiple areas.

    7. Router R1 uses a subnet mask of 255.255.255.0 and sits on the boundary of area 0 and area 1. Examine the following route configuration:
    OSPF 76 network 172.12.32.0 0.0.15.255 area 1
    Network 172.12.96.0 0.0.15.255 area 0
    Area 0 range 172.12.96.0 255.255.224.0
    Area 1 range 172.12.32.0 255.255.224.0


    Which of the following statements are true?

    An interface on this router with IP address 172.12.32.124 is in area 1.
    An effect of the fourth line is to reduce the number of route tables and trees.
    All networks within the range 172.16.64.0 to 172.12.95.0 will be summarized from area 0 into area 1.
    All networks within the range of 172.12.32.0 to 172.12.63.0 will be summarized from area 1 into area 0.
    Area 0 can act as a stub or transit area for routes including networks in the range of 172.12.96.0 with a mask of 255.255.224.0.

    8. In addition to viewing a routing table, the ____________ command can be used to determine if a router is using the best path to forward packets on a specific network.

    ping
    show path
    traceroute
    ping with record option

    9. You are configuring redistribution to advertise EIGRP routes into OSPF on a boundary router. Examine the configuration below:
    router ospf 7
    redistribute EIGRP 300 metric 20 subnets
    
    What is the function of the "20" paramters in the redistribute command?

    It is the seed to be applied to the redistributed routes.
    It replaces an administrative distance of 20 on the newly learned routes.
    It is the process-id for the PSEUDO process that injects the EIGRP routes into OSPF.
    It sets the network wieght to 20 for routes redistributed into OSPF.

    10. You are configuring a static route on a router. You want to configure it so that if the interface associated with the route goes down, it will still remain in the routing table. Which IP route command paramter is needed?

    Keep
    Backup
    Permanent
    Continuous

    11. You configure policy-based routing on interface Serial 0:
    interface serial 0
    ip policy route-map demo
    route-map demo permit 10
    match ip address 1
    set interface serial 2 serial 3
    access-list 1 permit 10.3.3.2 0.0.0.0
    

    If the packets were sourced from 10.3.3.2 it is a candidate for fast switch policy routing.
    If the packet was sourced from 10.3.3.2 it will be routed out interface serial 2 and interface serial 3 in a load sharing fashion.
    If the packet was destined for 10.3.3.2 it will be routed out interface serial 2 and interface serial 3 in a load sharing fashion.
    If the packet was sourced from 10.3.3.2 it will be routed out interface serial 2. If interface serial 2 is not up, the packet will be routed out interface serial 3.

    12. You must interconnect networks that use different routing protocols-the first uses IGRP and the second uses OSPF. You connect the networks using redistribution at the boundary routers. If the routers were to receive route information for the same networks from IGRP and OSPF, from which protocols will they select the route envoy?

    OSPF, because it is a link state protocol.
    OSPF, because it has a better seed matrix.
    IGRP, because it a hybrid routing protocol.
    IGRP, because it has a better administrative distance.

    13. Which command must be entered if you want the route 10.1.1.0 to be advertised or redistributed?

    ip route 10.1.1.0 255.255.255.255 E 1
    ip route 10.1.1.0 255.255.255.0 10.2.1.1
    ip route 10.1.1.0 255.255.255.0 interface E 1
    ip route 10.1.1.0 255.255.255.0 access-scripts 1

    14. The purpose of route summarization is to ______________.

    Use hierarchical routing to allow one route update to represent many down stream networks.
    Control route updates to lower their frequency and leave more bandwidth for applications.
    Use an addressing scheme that will assing networks sequentially, thus allowing them not to fragment.
    Use a compression logarithm on the routing table to lower memory constraints on the router.

    15. Which three of these statements are true concerning BGP?

    Periodic keep-alives are sent to verify TCP connectivity
    Reliability comes from using TCP port 179 for transport.
    Topology awareness is kept current routing periodic updates.
    A rich set of matrices called path factors enable BGP to support various routing policies.

    16. Which of the following is a characteristic of variable length subnet masking (VLSM) ?

    It allows a 32-bit subnet mask.
    It is supported by all routing protocols because they carry the subnet mask within their routing table updates.
    It allows a way of controlling the number of reliable hosts on the network by manipulating the mask in an attempt to efficiently allocate IP addresses.
    It allows the concurrent use of several different subnet masks on a single interface, thus providing multiple networks on a sibgle interface.

    17. By default, what happens to the next hop atttibute advertised by EBGP?

    It is ignored by IBGP.
    It is carried into IBGP.
    It is a MED with subnet mask before being carried into IBGP.
    It is modified by IBGP to be the address of the router that receives the update.

    18. What is the purpose of the "default-information originate always" command?

    It is used to create a default static route on a router running RIP.
    It is used to create a default static route on a router running OSPF.
    It is used to create a default static route on a router running EIGRP.
    It is required whenever you want to propagate a default route into a RIP autonomous system.
    It is required whenever you want to propagate a default route into an EIGRP autonomous system.
    It is required whenever you want to propagate a default route into an OSPF autonomous system.

    19. Which two statements about BGP communities are true?

    They are restricted to one AS.
    The are restricted to one class A or B or C network.
    They allow routers to filter incoming or outgoing updates.
    The are indicators used by routers to allow other routers to make decisions based upon these indicators.

    20. What are two characteristics of an autonomous system?

    It uses only interior gateway protocols (IGPs).
    It is a set of routers under a single technical administration.
    It uses IGPs to route packets to other autonomous systems and EGPs to route packets within the automous system.
    It uses EGPs to route packets to other automous systems and IGPs to route packets within the autonomous system.

    21. Which two statements about routers running EBGP are true?

    They are usually directly connected.
    They are not usually directly connected.
    They need to be able to reach each other.
    They do not need to be able to reach each other.

    22. Which two statements about BGP are true?

    BGP-based routing allows policy decisions at the AS level to be enforced.
    BGP can only advertise routers that it uses to be its peers in other autonomous systems.
    BGP can advertise routers that it's cat use to reach other autonomous systems.
    BGP allows an AS to send traffice to a neighboring AS, intending that the traffic take a different route than from the traffic originating in the neighboring AS.

    23. Which two statements are true about a router running BGP with all default settings?

    It will not run an IGP.
    It will always use a route learned by IBGP.
    It will not use a route learned by IBGP unless that route is learned from IGP.
    It will not advertise a route learned by IBGP to an external neighbor unless that route is learned from IGP.
    It will always advertise a route learned by IBGP to an external neighbor once connectivity to the external neighbor has been established.

    24. Which two events take place when a full mesh BGP session is configured within an autonomous system?

    The configuration is not permitted by default.
    Configuration may be permitted if route reflectors are used.
    This may result in many BGP sessions being created.
    This may result in many switched virtual circuits (SVC''s) being created.
    This may result in many permanent virtual circuits (PVCs) being created.
    This may result in using a significant amount of bandwidth on slow WAN links.

    25. What term is given to an autonomous system connected via BGP to more than one ISP?

    Multi-hop
    Multi-homed
    Multi-source
    Multi-assessed

    26. Which three IP protocols support variable length subnet masks(VLSM)?

    RIP v.1
    RIP v.2
    IGRP
    OSPF
    EIGRP

    27. Which three elements are required for a router to forward a packet?

    The best route.
    Possible routes.
    Destination address.
    Summarized route entry.
    Encryption key for routed data.

    28. In a routing table entry, which value indicates the best route to reach a destination network?

    Cost
    Metric
    Bandwidth
    Hop count

    29. What are two characteristics of link state routing?

    It is utilized by OSPF and IGRP.
    It determines paths by bandwidth-based value.
    It sends updates to directly attached routers only.
    It sends updates rather than complete routing tables when a network change occurs.

    30. Which two statements about variable length subnet masks are true?

    VLSMs are a characteristic of classful network.
    They have a greater capability to use route summarization.
    RIP v.1 network support multiple subnets per network address.
    VLSMs allow for more hierarchical levels within a testing plan.

    31. Given the following configurtation of Ethernet 0:
    ip address 172.16.80.77 255.255.255.0
    ip helper-address 172.16.90.255
    
    Which two statements are true?

    172.16.90.255 is an alternate address from 172.16.80.77.
    Host 172.16.90.255 is the backup router for 172.16.80.70.
    All non-routable protocols will be forwarded to 172.16.90.255.
    Host 172.16.90.255 will provide IP tunneling on IP protocols.
    BOOTP requests on the interface Ethernet 0 will be forwarded to network 172.16.90.0.
    NetBIOS broadcasts from 172.16.80.0 will be sent as directed broadcasts to network 172.16.90.0.

    32. Which two statements about VLSM are true?

    It supports hierarchical addressing.
    It is specifically used in the IP environment.
    It is specifically used in the IPX environment.
    It is specifically used in both the IP and IPX environments.

    33. In a multipoint WAN topology using EIGRP, which guideline is used for configuring bandwidth on a serial interface?

    Configure bandwidth to be the sum of all virtual circuits.
    Configure bandwidth to be equal to the lower CIR in the topology.
    Configure bandwidth equal to the link capacity divided by the number of its shared circuits.
    Configure bandwidth to be the product of a number of circuits multiplied by the CIR provisioned for each circuit in the topology.

    34. You are using routes with EIGRP route selection. What is a feasible distance?

    The next hop router for the backup path.
    The next hop router selected as the best path.
    The cost between the local router and the destination.
    The cost between the next hop router and the destination.

    35. When does EIGRP discover its neighbors?

    When it receives a hello packet from its neighbor.
    When it receives a full routing table from its neighbor.
    When it receives an acknowledgement of one of its transmitted hello packets.
    Due to the reliable nature of EIGRP, neighbor relationships are not required.

    36. Which EIGRP feature enables it to reduce the size of a routing table?

    Query scoping
    Hierarchical designs
    Route summarization
    VLSM

    37. When a route is stuck in inactive state, which EIGRP condition has occurred?

    The feasible successor router is not responding to update packets.
    The route compilation process is taking longer than usual to complete.
    The hold time has expired and a neighboring router has been marked as inactive.
    A neighboring router has failed to respond to a qeury about the router within 3 minutes.

    38. You are configuring EIGRP for NBMA operation. What is the purpose of the "ip bandwidth-percentage eigrp" command?

    It adjusts the percentage of bandwidth that EIGRP packets can use on all of the router's interfaces.
    It adjusts the percentage of bandwidth EIGRP packets can use on an individual router interface.
    It overwrites the bandwidth setting on an interface to ensure that EIGRP packets receive 50% of the available bandwidth on the rotuer's interface.
    It limits the percentage of bandwidth that EIGRP packets can use. The percentage cannot exceed 50% of the configured bandwidth on all of the router''s interfaces.

    39. For the purposes of participating in an OSPF DR/BDR election, what is the default router priority?

    1
    0
    32768
    255

    40. When configuring serial 1 for OSPF in NBMA mode, what is the correct combination of commands?

    interface serial 0
    ip ospf network non-broadcast
    neighbor address
    interface serial 0
    ip ospf network non-broadcast
    ospf process-id
    neighbor address
    interface serial 0
    ip ospf network nbma route
    router ospf process-id
    network number wildcard-mask area number
    neighbor address
    interface serial 0
    ip ospf network non-broadcast
    router ospf process-id
    network number wildcard-mask area number
    neighbor address

    41. Why is OSPF better than RIP v1 in a large network? (choose two)

    OSPF has fewer tables to manage.
    OSPF is a simpler protocol than RIP.
    OSPF has virtually no reachability limits.
    OSPF selects the best path using a metric that is based on bandwidth.

    42. What is mandatory to configure OSPF?

    router ospf network address
    router ospf area-id network address wildcard-mask
    router ospf process-id network address wildcard-mask area id
    router ospf process-id interface address wildcard-mask area-id

    43. Which subnet mask should be used to support two host addresses on the WAN segments.

    255.255.255.252
    255.255.255.30
    255.255.255.192
    255.255.255.0
    255.255.252.0

    44. When a helper address has been configured on a router, which command is used to prevent TACACS UDP port 49 requests from being forwarded by the router?

    no ip forward-protocol udp 49
    ip forward protocol udp neq 49
    no ip helper-address udp tacacs
    access-list 101 udp deny any eq tacacs

    45. Which two addresses can be summarized by the address, 172.30.16.0/20?

    172.30.15.0/24
    172.30.17.0/24
    172.30.31.0/24
    172.30.32.0/24

    46. In which 3 of the following instances should BGP be used?

    When there are multiple connections to the Internet.
    When there is a low bandwidth connection between autonomous systems.
    When route selection to routers outside of the autonomous system is not a concern.
    When the flow of traffic entering and leaving an autonomous system must be manipulated.
    When an autonomous system allows packets to transit through it to reach other autonomous systems.

    47. In which 3 of the following situations should BGP not be used?

    When there is a signle connection to the Internet.
    When there is alow bandwidth connection between autonomous systems.
    When route selection to routers outside of the autonomous system must be manipulated.
    When an autonomous system allows packets to transit through it to reach other autonomous systems.
    When route selection to routers outside of the autonmous system is not a concern.

    48. Given the following router A configuration:
    router bgp 65050
    network 10.1.0.0
    neighbor 172.17.1.1 remote-as 65000
    
    What are two effects of the above configuration on router A?

    Line 3 identifies a peer router to router A.
    The 65000 in line 3 identifies the AS that router A is in.
    The 65050 in line 1 identifies the AS that router A is in.
    Line 2 starts up the routing of BGP packets into network 10.0.0.0
    Line one starts up the routing of BGP packets into network 10.0.0.0

    49. BGP peers are also known as ____________ .

    IBGP
    EBGP
    Clients
    Reflectors
    Neighbors

    50. An autonomous system is connected via BGP to more than one ISP. The ISP sends only default routes into the autonomous system. What path will non-BGP routers in the autonomous system use as the best path to any external address?

    The shortest AS path.
    The path with the lowest weight.
    The path with the lowest IGP metric to the default router.
    The path leading to the router with the lowest BGP router ID.

    51. An autonomous system is connected via BGP to more than one ISP. What results when the ISP's send only default routes to the autonomous system?

    Low memory but high CPU usage.
    High memory but low CPU usage.
    Low memory and low CPU usage.
    High memory and high CPU usage.

    52. What method of sending route information into the BGP routing protocol is not recommended?

    Using the null 0 interface.
    Using the network command.
    Redistributing static routes into BGP.
    Redistributing dynamic routes into BGP.
    Using the 'redistribute BGP' command.
    Changing the administrative distance of the route.

    53. What should be used to prevent all RIP routing updates from being sent through selected interfaces without using access-lists?

    Static routes.
    Default routes.
    Passive interface.
    Route update filtering.

    54. You have configured policy-based routing on a router running Cisco IOS release 11.2. By default, which switching mode will the router use to forward packets that match the established policy?

    Fast.
    Slow.
    Process.
    Packets will be routed, not switched.

    55. You are configuring redistribution to advertise RIP routes into EIGRP on a boundary router. You specify a speed metric with the default-metric command. What is the format of the metric being specified.

    bandwidth delay reliability load
    hop-count
    bandwidth delay hop-count load
    load delay hop-count reliability

    56. Which statement about route filtering is true?

    Only outbound routes can be filtered.
    Routes to be filtered are selected using standard access lists.
    Routes to be filtered are selected using only extended access lists.
    Routes to be filtered are selected using the "distribute-group" command.

    57. You have configured redistribution between RIP and OSPF on your network and want to verify that redistribution is operating correctly. Which command can provide the information necessary to verify proper operation?

    ping
    show ip route
    show cdp neighbor
    show ip ospf neighbor

    58. Route distribution is requred for two routing domains with dissimilar metric structure in order to have complete toplogy awareness. Which two statements about route distribution are true?

    It is a requirement of redistribution that route summarization occur at class A, B, and C network boundaries.
    In good network design, the routing domains only interconnect at the routers where distribution is configured.
    Routes from one domain are assigned a speed metric to indicate their reachability prior to being injected into the other domain.
    If sufficient bandwidth is available to handle the routing updates associated with both protocols, running concurrent route redistribution may not have to be configured.

    59. Which statement most accurately describes the difference between classful and classless routing protocols?

    Classless routing protcols send event trigger updates and classful routing protocols send routine periodic router advertisements.
    Classful routing protocols are simply metrics; classless routing protocols use more complex metrics in their best path selection process.
    Classful routing protocols do not carry the subnet mask within routing updates. Classless routing protocols use the subnet mask for each network in their routing updates.
    Classless routing protocols require route summarization to occur at class A, B, and C network boundaries. Classful routing protocols allow route summarization to occur at any point within the network.

    60. A route map can be used to control and modify routing information. Which two of the following statements about route maps are true?

    Route maps can be defined either by name or by number.
    Route maps can use standard or extended access lists to define match conditions.
    Route maps can change the attributes of a received route but do not block the advertisement from reaching the routing table.
    Once a match condition occurs and the corresponding set condition has been applied, execution of the route map is terminated.

    61. On a router that can learn network topology using both RIP and IGRP, which routes will be placed in the routing table and why?

    The RIP routes because they have a smaller metric value.
    The IGRP route because they have a larger metric value.
    The RIP routes because they have a larger administrative distance.
    The IGRP routes because they have a smaller administrative distance.

    62. Which three of the following are characteristices of distance vector routing?

    it is utilized by RIP and IGRP.
    It sends updates to all routers in an area.
    It is the simplest routing protocol to configure.
    It sends period updates even when no network change has occurred.

    63. Which field is missing from RIP v! routing updates for supporting variable lenght subnet masks?

    Cost metric
    Subnet mask
    Hop count limit
    Network layer address

    64. What does the time value represent in a routing table entry?

    The amount of time that has expired since the routing table was created.
    It is an incrementing counter that indicates when the next routing update is expected for the route.
    The amount of time since a hello packet was received from a neighbor that advertised the route.
    It is an incrementing counter that indicates how long the route has been in the table since the last update.

    65. Given the following configuration for R3:
    router ospf 110
    network 192.168.32.0 0.0.0.255 area 2
    network 192.168.33.0 0.0.0.255 area 0
    area 2 stub no-summary
    area 2 default-cost 10
    
    Which three of the following statements area true?

    Area 2 is a totally stubby area.
    If the backbone becomes discontiguous, traffic can be routed through area 2.
    R3 adds 10 to the internal cost when it inputs the default route into the stub area.
    Redistribution of other routing protocols takes place at the area-designated router.
    Router 2 non-ABR routes will contain only intra-area routing information and a default route.

    66. Which command is used to verify the status of an OSPF virtual link?

    show ip ospf
    show ip ospf database
    show ip ospf interface
    show ip ospf virtual-link

    67. OSPF routers can route when they are in which state?

    Full state
    Two-way state
    Exchange state
    Forwarding state

    68. A multi-area OSPF network places which restriction on the use of an NBMA topology?

    The NBMA portion of the network must be in area 0.
    The NBMA portion of the network must not be in area 0.
    There are no restrictions of NBMA topologies.
    All areas that incorporate NBMA topology must be full mesh but cannot be configured as stub areas.

    69. Which entries are kept in EIGRP routing tables?

    All learned routes.
    Successor routes only.
    Feasible successor routes only.
    Successor and feasible successor routes.

    70. How does an EIGRP route determine when a neighbor is unavailable?

    When the hold time is exceeded.
    When the query value exceeds zero.
    When the queue value is constantly at zero.
    When the round trip time exceeds 500 milliseconds.

    71. Which routing protocols support multiple link network routed protocols?

    OSPF
    EIGRP
    RIP v1
    RIP v2

    72. How can route summarization be performed on an EIGRP network?

    Manually at any interface within the network.
    Only at autonomous system boundary routers.
    Automatically by the master router in each area.
    Route summarization is not required because EIGRP support of VLSM.

    73. You want to configure EIGRP for IP. Which command enables EIGRP and defines the autonomous system?

    router eigrp autonomous-system-number
    config eigrp autonomous-system-number
    router ip eigrp autonomous-system-number
    config ip eigrp autonomous-system-number