Online Quizzes

CCNA Practice Test

    1. Which two statements about store and forward switching method are true?

    Latency remains constant regardless of the frame size.
    Latency through the switch varies with frame length.
    The switch receives the complete frame before beginning to forward it.
    The switch checks the destination address as soon as it receives the header and begins forwarding the frame immediately.

    2. Which two physical interfaces support PPP?

    Ethernet
    Token Ring
    Synchronous Serial
    Asynchronous Serial

    3. Consider a method for transporting frames through a switch that checks the destination address in the frame header and immediately begins forwarding the frame. What is this frame transmission method called?

    CSMA/CD
    Full-Duplex
    Cut-Through
    Half-Duplex
    Fragment-Free
    Store-and-forward

    4. Which command would you use to enable IP/RIP version 1 on a router?

    Router RIP
    network 172.16.1.0
    network 10.1.0.1
    Router RIP
    network 172.16.0.0
    network 10.0.0.0
    Router RIP
    network 172.16.1.0 172.16.1.1
    network 10.1.0.0 10.1.1.1
    Router RIP
    network 172.16.1.0 265.255.255.0
    network 10.1.0.0 255.255.0.0

    5. During encapsulation, in which order is information packaged?

    Data, Segment, Packet, Frame
    Data, Packet, Segment, Frame
    Segment, Data, Packet, Frame
    Packet, Data, Segment, Frame

    6. Which of the following is an example of a valid MAC address?

    192.201.63.251
    19-22-01-63-25
    000.1234.FEG
    00-00-12-34-FE-AA

    7. What are two purposes for using switches?

    To reduce collisions
    To increase the number of collision domains
    To decrease the number of collision domains
    To decrease the number of broadcast domains
    To increase collisions

    8. Within a heirarchial number of IP addresses, what determines the portion of the address that will identify the network number?

    Subnet Mask
    Dots between octets
    Class of first octet
    Assignments of DHCP
    Address-resolution process

    9. Which three functions are supported by connection-oriented services?

    Connection parameters are synchronized
    Any loss or duplication of packets can be corrected
    The data packet is independently router and the service does not guarantee the packet will be processed in order
    A data communications path is established between the requesting entity and the peer device on the remote end system

    10. Which two statements about reliable connection-oriented data transfer are true?

    Recipients acknowledge receipt of data
    When buffers are filled to capacity, datagrams are discarded and not transmitted
    Windows are used to control the amount of outstanding acknowledged data segments
    If the segments timer expires between receipt of the acknowledgement the sender drops the connection
    The receiving device waits for acknowledgements from the sending device before accepting more data segments

    11. What is the result of segmenting a network with a bridge?

    It increases the number of collision domains
    It decreases the number of collision domains
    It increases the number of broadcast domains
    It decreases the number of broadcast domains

    12. Each department has its own file server and the company has an enterprise server that is shared by all departments. What does the network administrator use to provide a secure separation between the management and sales department?

    Bridge between management and sales
    Bridge between management and sales
    Routers to provide the most secure segmentation
    A hub to provide the ease of management and a satisfactory alternative for the network security
    An Ethernet switch to secure separation by programming the access list of each port of the switch

    13. What was the key reason for creating the International Organization for Standardization that released the OSI model?

    Users could access network servers faster
    Different vendor networks could work with each other
    The industry could create a standard for how computers work
    Network Administrators could increase the overall speed of their network

    14. Given the IP address 192.168.21.12 for the class C address range your network needs address for 28 small offices. Each office uses its own subnet. The network designs specify that you configure for 5 bits of subnetting when you configure the Cisco IOS software. Which subnet mask should you use?

    255.255.255.224
    255.255.255.0
    255.255.255.28
    255.255.255.248
    255.255.255.252

    15. What is the link state routing protocol used in the TCP/IP protocol stack?

    IP
    IS-IS
    NLSP
    OSPF
    RIP ver 2

    16. Which two commands allow you to verify address configuration in your network?

    Ping
    Verify
    Traceroute
    Test IP
    Echo IP
    Config IP

    17. Which two IPX encapsulation names are correctly paired with their Cisco IOS encapsulation names?

    Ethernet_II-ARPA
    Ethernet_802.3-SAP
    Ethernet_802.2-LLLC
    Ethernet_SNAP-SNAP

    18. In which modes can the ICMP ping command be used? (Choose all that apply)

    User
    Privileged
    Global Configuration
    Interface Configuration

    19. Which command sets IGRP as the routing protocol for autonomous system 100?

    Router(config)# IGRP 100
    Router(config)# NETWORK 100
    Router(config)# router IGRP 100
    Router(config)# enable IGRP 100

    20. You have a frame relay link on Serial. Which command displays the local management interface LMI data link connection identifier DLCI and bandwidth for that link?

    show interface serial1
    show frame-relay serial1
    show protocol frame-relay serial1
    show serial1 encapsulation frame-relay

    21. What is the total bandwidth of all channels on a PRI circuit?

    64 kps
    128 kps
    144 kps
    1.536 Mbsp
    1.544 Mbsp

    22. Your company has an employee that works at home. The employee runs big client-server applications and must quickly transfer large files. The company wants the best cost benefit on this connection. What would be the most practical solution?

    An ISDN basic rate interface (BRI) connection to the user's home
    A dedicated T1 connection to the user's home
    A dedicated frame-relay connection to the user's home
    A standard 28.8 analogue dial up connection to the user''s home

    23. What does the frame relay switch use to distinguish between each PVC connection?

    CNs
    FECNs
    Local Management interface LMI
    ata link connection identifier (DLCIs)

    24. You are configuring a frame relay router with sub interfaces on interface serial 0. Which sub interface number could you use for this configuration?

    1 and 2
    0.2 and 0.3
    1 and 1.1
    0.1a and 0.1b

    25. Given the following criteria for granting access from a remote router site to your LAN:

    Restrict access on interface E0
    E0=128.12.22.55
    deny access to telnet, FTP
    All other types of operations.

    Which line should come last in configuring your access list?

    Access-List 101
    Access-List 101 deny E0 telnet FTP
    Access-List 101 allow all except FTP telnet
    Access-List 101 permit IP 0.0.0.0 255.255.255.255 any
    Access-List 101 deny TCP 128.12.22.55 EQ 20 21 23

    26. What is the maximum length of a fast Ethernet cable 100BaseTx standard?

    10m
    50m
    100m
    185m
    1000m

    27. Which command displays access list 111?

    show access-list 111
    show 111 IP access-list
    display IP address-list
    display access-list 111 details

    28. What is 'back off' on an 802.3 network?

    It is latency stored and forward switching
    It is time used for token passing from machine to machine
    It is retransmission delay that is encountered when a collision occurs
    It is the result of two nodes transmitting at the same time; the frames from each transmitting device collide and are damaged

    29. Which symbol in the router prompt indicates that you are in priveleges mode?

    #
    !
    >
    /
    :

    30. Which statement about half duplex Ethernet operation is true?

    With half duplex, transmission frames feed into a single cable in one direction at a time.
    Half duplex transmission between stations is achieved by using point to point Ethernet and fast Ethernet connection.
    Half duplex transmission between stations is achieved by using point to multi point Ethernet and fast Ethernet connection.
    Half duplex Ethernet technology provides a transmit circuit connection wired directly to the receiver circuit at the other end of the connection.

    31. Question # 31 : You enter the following command:
    router(config)line console 0
    
    Which operation is most likely to follow?

    Configure terminal type
    Create a password on the console terminal line
    Establish a terminal type 4 connection to a remote host
    Change from configuration mode to console privileged mode

    32. Which command assigns the login password 'Cisco' on the console terminal line?

    line vty 0
    Login
    Password Cisco
    Line Console
    Login
    Password Cisco
    Line login terminal
    Password Cisco
    Line serial 0
    Login
    Password Cisco
    Line console 0
    Login
    Password Cisco

    33. How do you get help on a command after you have received the "% INCOMPLETE COMMAND" response from the switch?

    Type show help
    Enter a question mark to display all console commands
    Type a ? and then the command
    Re-enter the command followed by a question mark to view key words

    34. Which three commands are used to configure information in RAM on a router?

    Configure memory
    Configure terminal
    Configure overwrite
    Copy TFTP startup-config
    Copy startup-config running-config

    35. Which command loads a new version of Cisco IOS into the router?

    Copy flash tftp
    Copy tftp flash
    Copy ftp flash
    Copy flash ftp

    36. Which two solutions are used to reduce the chance of distance vector routing loops?

    Split horizon
    Route Poison
    Area Hierarchies
    Link State Algorithms

    37. While you are preparing the initial configuration of your router and enable IP you find you need to use a Telnet session to check for a network address parameter. Your Telnet logging and your virtual transmission session on the other device are successful. By default, what must you enter to suspend your Telnet session and return to the original router?

    Suspend
    The command 'exit'
    CONTROL-ESC followed by 'x'
    CTRL-Shift-6 followed by ''x''
    CTRL-ALT-DEL followed by 'x'

    38. Which exec command displays system configuration, software version and the names and source of configuration files and boot images on a router?

    show boot
    show flash
    show version
    show config

    39. What are the primary operating modes for frame switching? (Choose all that apply)

    Full duplex
    Half duplex
    CSMA/CD
    Cut through
    Fragmentation
    Store and forward

    40. A router on the other side of a PPP link uses the host name RTR1 and the password CORP-PWD. Which configuration line on RTR1 enables the connection between RTR1 and the other router named RTR2?

    Username RTR2 password CORP1-PWD
    Username RTR1 password CORP1-PWD
    Username RTR2 password CORP2-PWD
    Username RTR1 password CORP2-PWD

    41. Which statements about a bridge are true? (Choose all that apply)

    A bridge floods multicasts
    A bridge floods broadcasts
    A bridge does not flood multicasts
    A bridge does not flood broadcasts

    42. Which statement about an IP network is true?

    A broadcast source MAC contains all zeros
    A MAC address is part of the physical layer of the OSI model
    MAC addresses are used by bridges to make forwarding decisions. IP addresses are used by routers
    IP addresses are now a flat addressing scheme--MAC addresses use a hierarchical addressing scheme

    43. Which statement about the specialized IP addresses shown below is true?

    10.0.0.0 to 10.255.255.255
    172.16.0.0 to 172.31.255.255
    192.168.0.0 to 192.168.255.255

    They are private IP addresses
    They can be leased with DHCP
    They are allocated for VOL PVOLP
    They represent IP classless addresses
    They are used by the internal NIC for administration

    44. What are four functional characteristics of the network layer of the OSI model?

    It uses a two part address
    It maintains routing tables
    It uses broadcast addresses
    It establishes network addresses
    It provides access to the LAN media
    It provides media independence for upper layers
    It provides path selection for internetwork communication

    45. Which basic switch functions increase available bandwidth on the network? (Choose all that apply)

    Loop avoidance
    Address learning
    Hop count limiting
    Broadcast filtering
    Packet forwarding/filtering

    46. You have just issued an erase startup-config command and reloaded you router. In which mode will your router be when you reboot?

    Setup
    Startup
    User EXE
    User Privileged
    Global configuration

    47. Which of these commands sets RIP as the routing protocol?

    Router# rip
    Router rip
    Router (config)# rip
    Router (config)# router rip

    48. What are two components of an IPX packet?

    Network number; IP address
    MAC address; node number
    Network number; MAC address
    Network number; subnet number

    49. Which network mask would you place on a Class C address to accommodate a user requirement of two sub networks with a maximum of 35 hosts on each network?

    255.255.255.192
    55.255.255.224
    225.255.255.240
    255.255.255.248
    255.255.255.252

    50. Which command mode is necessary to enter the extended ping command?

    Router>
    Router(config)#
    Router(ext-ping)#
    Router#

    51. Which of the following are true of subnetting a Class C network?

    Maximum subnet bit will be 6
    Each subnet will have a maximum of 254 hosts
    Maximum number of 62 subnets
    Each subnet will have a maximum of 252 hosts
    Maximum number of subnets is 64

    52. Which statement is true when a broadcast is sent in an Ethernet/802.3 LAN?

    The IP subnet used is 255.255.255.0
    The IP address used is 255.255.255.255
    The MAC address used is 00-00-00-00-00-00
    The MAC address used is FF-FF-FF-FF-FF-FF

    53. Which of these commands will configure the clock rate for 56000 on serial 0 interface?

    Router# clock rate 56000
    Router(config-if)#clock rate 56000
    Router(config-if)#clock rate 56k
    Router(config)#int serial0 clock rate 56000

    54. Which command allows the user to see a system message when logging into a router?

    Banner MOTD
    Message MOTD
    Banner Message
    Message Banner

    55. If you are in IOS user mode, which command do you use to enter the privileged mode?

    Set
    Enable
    Configure
    Privileges

    56. On a network design project you determine that a new testing application requires multiple hosts. The hosts must be capable of sharing data between each host and an enterprise server at 10 Mbps bandwidth. Other divisions in the company use applications that require less that 2 Mbps bandwidth from the enterprise server. What is your economical recommendation?

    That existing 10baseT hubs be replaced with 100BaseT hubs to inprove overall performance.
    That a router can separate the testing application from the rest of the network, thus allowing the testing application more bandwidth.
    That a switch be instaleed so that the enterprise server can be provided a 100 Mbps port and each of the testing application haosts can be given dedicated 10 Mbps ports
    That a bridge be placed between the enterprise server and all other users--with the exception of the testing application

    57. What is the bandwidth capacity of an ISDN B channel?

    64 Kbps
    128 Kbps
    16 Kbps
    512 Kbsp
    1.544 Mbps

    For the following 8 questions use the following IP address
    193.108.250.136/25


    58. Convert to binary.

    11000011.01101100.11111010.10001000
    11000001.01101100.11111010.10001000
    11000001.01101110.11111010.10001000
    11000001.01101100.11111010.10001100

    59. What is the subnet mask?

    255.255.255.128
    255.255.255.192
    255.255.128.0
    255.255.192.0

    60. What is the network address?

    193.108.250.127
    193.108.250.128
    193.108.250.0
    193.108.250.1

    61. What is the broadcast address?

    193.108.250.127
    193.108.255.255
    193.108.250.255
    193.108.250.254

    62. How many IP addresses?

    128
    64
    192
    255

    63. How many usable IPs?

    62
    190
    253
    126

    64. First usable IP address?

    193.108.250.128
    193.108.250.129
    193.108.250.1
    193.108.250.0

    65. What class is this IP address?

    A
    B
    C
    D
    E