Dial-on-Demand Routing (DDR)

Introduction

Short for Dial-on-Demand Routing. DDR is a routing technique developed by Cisco that allows a user to utilize existing telephone lines, or public circuit-switched networks, to form a WAN instead of lines that are dedicated specifically to the WAN. DDR is typically implemented by users that do not need permanent, continuous links between sites on the WAN because the volume of traffic over the WAN is low and the transmissions are periodic as opposed to continuous. The connection only becomes active when data is sent to the remote site. When no data has been sent over the link for a specified amount of time, the link is disconnected.

Using DDR, a connection between sites is only established when a specific type of traffic initiates the call or when you a backup link is needed for redundancy or load sharing.

DDR is used in order to save on the costs of a dedicated WAN line for organizations that do not need permanent continuous connection and as a back-up by organizations that use the dedicated line for critical applications.

Configuration

version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R2
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local
!
username admin privilege 15 password 7 <deleted>
username R3 password 7 <deleted>

!--- For CHAP, passwords must be the same on both routers.

ip subnet-zero
!
isdn switch-type basic-5ess
!
interface Ethernet0
ip address 172.22.95.1 255.255.255.0
!
interface BRI0
ip address 172.22.86.2 255.255.255.0
encapsulation ppp
dialer map ip 172.22.86.1 name R3 6663000
dialer-group 1
isdn switch-type basic-5ess
ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.22.86.1
!
dialer-list 1 protocol ip permit
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

More Information

More configuration examples can be found at the following two other articles: