Gathering Solaris System Information

Processors

The psrinfo utility displays processor information. When run in verbose mode, it lists the speed of each processor and when the processor was last placed on-line (generally the time the system was started unless it was manually taken off-line).

PRMS:prms> psrinfo
0       on-line   since 09/17/2009 14:26:54
1       on-line   since 09/17/2009 14:27:21
2       on-line   since 09/17/2009 14:27:21
3       on-line   since 09/17/2009 14:27:21
8       on-line   since 09/17/2009 14:27:21
9       on-line   since 09/17/2009 14:27:21
10      on-line   since 09/17/2009 14:27:21
11      on-line   since 09/17/2009 14:27:21
16      on-line   since 09/17/2009 14:27:21
17      on-line   since 09/17/2009 14:27:21
18      on-line   since 09/17/2009 14:27:21
19      on-line   since 09/17/2009 14:27:21
24      on-line   since 09/17/2009 14:27:21
25      on-line   since 09/17/2009 14:27:21
26      on-line   since 09/17/2009 14:27:21
27      on-line   since 09/17/2009 14:27:21
PRMS:prms>

Or the full version with information about each processor.

PRMS:prms> psrinfo -v
Status of virtual processor 0 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:26:54.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 1 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 2 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 3 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 8 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 9 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 10 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 11 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 16 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 17 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 18 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 19 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 24 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 25 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 26 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 27 as of: 10/28/2009 14:09:47
  on-line since 09/17/2009 14:27:21.
  The sparcv9 processor operates at 2150 MHz,
        and has a sparcv9 floating point processor.
PRMS:prms>

The psradm utility can enable or disable a specific processor.

To disable a processor:
/usr/sbin/psradm -f processor_id

To enable a processor:
/usr/sbin/psradm -n processor_id

The psrinfo utility will display the processor_id when run in either standard or verbose mode.

RAM

The prtconf utility will display the system configuration, including the amount of physical memory.

To display the amount of RAM:

PRMS:prms> prtconf | grep Memory
Memory size: 32768 Megabytes
PRMS:prms>

Disk Space

Although there are several ways you could gather this information, the following command lists the amount of kilobytes in use versus total kilobytes available in local file systems stored on physical disks. The command does not include disk space usage from the /proc virtual file system, the floppy disk, or swap space.

df -lk | egrep -v "Filesystem|/proc|/dev/fd|swap" | awk '{ total_kbytes += $2 } { used_kbytes += $3 } END { printf "%d of %d kilobytes in use.\n", used_kbytes, total_kbytes }'
19221758 of 135949755 kilobytes in use.

You may want to convert the output to megabytes or gigabytes and display the statistics as a percentage of utilization.

The above command will list file system usage. If you are interested in listing physical disks (some of which may not be allocated to a file system), use the format command as the root user, or the iostat -En command as a non-privileged user.

PRMS:prms> iostat -En
c0t1d0           Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
Vendor: SEAGATE  Product: ST914602SSUN146G Revision: 0603 Serial No: 084898913R
Size: 146.80GB <146800115712 bytes>
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 0 Predictive Failure Analysis: 0
c0t0d0           Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
Vendor: SEAGATE  Product: ST914602SSUN146G Revision: 0603 Serial No: 090398KWJ0
Size: 146.80GB <146800115712 bytes>
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 0 Predictive Failure Analysis: 0
c0t3d0           Soft Errors: 2 Hard Errors: 0 Transport Errors: 0
Vendor: TEAC     Product: DV-W28E-R        Revision: M.0B Serial No:
Size: 0.00GB <0 bytes>
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 2 Predictive Failure Analysis: 0
c5t60050768018F02FB2000000000001392d0 Soft Errors: 1 Hard Errors: 0 Transport Errors: 0
Vendor: IBM      Product: 2145             Revision: 0000 Serial No:
Size: 53.68GB <53678702592 bytes>
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 1 Predictive Failure Analysis: 0
c5t60050768018F02FB2000000000001391d0 Soft Errors: 1 Hard Errors: 0 Transport Errors: 0
Vendor: IBM      Product: 2145             Revision: 0000 Serial No:
Size: 107.37GB <107365793792 bytes>
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 1 Predictive Failure Analysis: 0
c5t60050768018F02FB2000000000001390d0 Soft Errors: 1 Hard Errors: 0 Transport Errors: 0
Vendor: IBM      Product: 2145             Revision: 0000 Serial No:
Size: 107.37GB <107365793792 bytes>
Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
Illegal Request: 1 Predictive Failure Analysis: 0
PRMS:prms>

Process and Kernel, 32 or 64 bit

If you are running Solaris 2.6 or earlier, you are running a 32-bit kernel.

Determine bits of processor:

PRMS:prms> isainfo -bv
64-bit sparcv9 applications
        fmaf vis2 vis popc

Determine bits of Solaris kernel:

PRMS:prms> isainfo -kv
64-bit sparcv9 kernel modules