Cisco T1 Guide

Example T1 Configuration
Adding a Secondary Ethernet IP
Troubleshooting Connectivity Problems

Example T1 Configuration

service udp-small-servers
service tcp-small-servers
!
hostname Atlanta
!
enable secret cisco
!
ip subnet-zero
ip domain-lookup
ip name-server 129.250.35.250 129.250.35.251
!
interface Ethernet0
 ip address 209.39.6.1 255.255.255.0
!
interface Serial0
 description Leased Line to Boston
 encapsulation ppp
 ip address 199.1.138.2 255.255.255.252
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
!
line con 0
 password console
 login
line aux 0
line vty 0 4
 password telnet
 login
!

Adding a Secondary Ethernet IP

Adding a secondary Ethernet IP block is an easy quick process on a Cisco router. Get into privledged exec mode and then, assuming that Ethernet 0 is your main Ethernet interface, run the following commands:

router>enable
Enter password:
router#conf t
router(config)#interface Ethernet0
router(config-if)#ip address 172.16.0.1 255.255.255.0 secondary

The secondary statement specifies that the IP block listed is a secondary IP block on that interface. Substitute the appropriate block for your needs.

Troubleshooting Connectivity Problems

Troubleshooting T1 connectivity problems is a process of determining where the fault resides. Follow these steps when troubleshooting a T1 problem to get the best results:

  1. Power cycle the router and CSU/DSU if applicable.
  2. Perform a show interface on both sides of the line if possible. See the Cisco Interface Description page for information on interpretting the output.
    1. Most of the time, if you are seeing errors on both sides of the line, then you are seeing a telephone company problem. In some rare cases, this can also be indicative of the incorrect timing settings in one or both of the CSU/DSU's.
    2. If you are only seeing problems on one side of the line, then it could be a cabling problem, a bad CSU/DSU, or a bad router.
    3. If neither side is reporting any problems and the line shows up, then continue with the next step.
  3. If the line shows up on both sides, then you are most likely looking at a routing problem. See if you can ping either the customer's serial or ethernet IP of the router.
    1. >If you can ping both, then you are most likely looking at a LAN problem, although you could be looking a bad route statement on the ISP side.
    2. If you can only ping the serial IP address, then either the customer is running a firewall/NAT or the Ethernet IP's are not being routed correctly to the customer.
    3. If you can ping neither the Serial IP or the Ethernet IP, then this could be a routing problem or it could be a telco problem. Ensure that the customer's IP's are routing through the correct Serial interface on the ISP's side and if so, then have the telephone compnay run an intrusive line test on the line to check for errors in transmissions across the line.
  4. A final step you can try is to debug the interface by running debug serial interface from a priveledged exec prompt. To turn it off when you're done, type no debug serial interface or no debug all. Below is a screen shot example of what you will see: