service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname HOSTNAME
!
enable password ENABLEPASSWORD
!
ip subnet-zero
ip name-server 129.250.35.250
ip name-server 129.250.35.251
isdn switch-type basic-ni1
ip routing
!
interface Ethernet 0
no shutdown
description connected to EthernetLAN
ip address IPADDRESS SUBNETMASK
no keepalive
!
interface Serial0
no shutdown
description Leased Line to Infomart
service-module t1 framing esf
service-module t1 linecode b8zs
ip address 199.1.127.2 255.255.255.252
encapsulation hdlc
!
interface BRI0
description ISDN Backup to Verio
ip unnumbered Ethernet0
no ip mroute-cache
encapsulation ppp
isdn spid1 SPID1 DIRECTORYNUMBER1
isdn spid2 SPID2 DIRECTORYNUMBER2
dialer rotary-group 1
no fair-queue
no shutdown
!
interface Dialer1
ip unnumbered Ethernet0
no ip mroute-cache
encapsulation ppp
bandwidth 128000
dialer in-band
dialer idle-timeout 3600
dialer string ISDNDIALNUMBER
dialer load-threshold 1 outbound
dialer-group 1
ppp authentication pap callin
ppp pap sent-username USERNAME password PASSWORD
ppp multilink
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
ip route 0.0.0.0 0.0.0.0 Dialer1 100
access-list 103 permit ip any any
dialer-list 1 protocol ip permit
!
line console 0
password CONSOLEPASSWORD
login
exec-timeout 0 0
!
line vty 0 4
password TELNETPASSWORD
login
!
end
!